Web Hosting Domain Names dnHost Site
Προηγμένη αναζήτηση Αναζητήστε τη γνωσιακή βάση

Κάλυψη κενού ασφαλείας OpenCart <= 1.5.6.4 (cart.php) PHP Object Injection Vulnerability

Προβολές: 6200 Τελευταία ενημέρωση: 04/09/2017 13:44 0 Βαθμολογία/ 16 Χρήστες

Ακόμα και αν είστε στην 1.5.6.4 δεν καλύπτεστε από αυτό το major κενό ασφάλειας http://www.securityfocus.com/archive/1/532763 

Εκτός και περάσετε την σχετική επιδιόρθωση (patch): https://github.com/opencart-ce/opencart-ce/commit/c2aafc823bd85876f5e888f8ebc421069a5e076f 

Αλλιώς εγκαταστησετε την τελευταία έκδοση του OpenCart 2.0 από το http://www.opencart.com/index.php?route=download/download 

Επίσης θα πρέπει να αναβαθμίσετε και κάθε extension/template που τυχόν έχετε εγκατεστημένο.

Αν η αναβάθμιση της τελευταίας έκδοσης σας φοβίζει διότι πιθανόν κάποια από τα extensions/modules να μην έχουν αναβαθμιστεί, μπορείτε να αναζητήσετε αν τα πρόσθετα σας είναι συμβατά με το OC 2.0 

Αν είναι μπορείτε να κάνετε την αναβάθμιση, αφού πρώτα πάρετε ένα Plesk backup :)

Αν κάποιο πρόσθετο/template δεν είναι ακόμα συμβατό με το OpenCart 2ενδεχομένως κάποιο παρόμοιο να είναι.